Posts: 10
Joined: Wed Oct 13, 2021 3:58 pm

Emergency need for deprecated export server dependencies.

I have an emergency need to build an older version of the high charts export server. However to satisfy my requirements, I need high stock. But, I am building export server version 2.0.1 and need high stock version 4.0.1. But I cannot get version 4.0.1 from the CDN or anywhere else I've tried. Is there an archive anywhere?
Posts: 1266
Joined: Fri Dec 16, 2022 11:45 am

Re: Emergency need for deprecated export server dependencies.


Thanks for the question!

The Export Server <= 3.0 is based on PhantomJS ( which has been deprecated for a few years now. It has a lot of bugs which will not be solved as this solution is not currently maintained. It is not recommended to use it, but if you do, keep in mind that this is not officially supported and no updated are planned for the 2.0 version.

If I may ask, what is the reason you decide to build an older version instead of staying with the latest one? In the latest version it's super easy to use Highcharts Stock.

If you're looking for a JS file for a specific version, you can download them here: (download button next to the headers - downloads a full .zip with all you need).

Best regards!
Highcharts Developer

Return to “Highcharts Usage”